× If you expect answers you should describe your problem and give as much information's as possible. (SQL-Structure, Template Code, Joomla Version ...) Please read this before posting: joodb.feenders.de/support.html

error code; 1054, unknown collum ‘ a.title’ in ‘where clause’

  • martijn
  • Offline
  • specialised in front end
More
1 month 2 weeks ago #7096 by martijn
JooDatabase version: 4.0.1
Database format: SQL
Connection type: external database

error code; 1054, unknown collum ‘ ’ in ‘where clause’ is what I get when clicking on the main menu link

Which field/collumn in my orginal database does JooDatabase choose to assign to '' ?

I have no clue how to solve it since no colum in my SQL database is called ''

This message has an attachment image.
Please log in or register to see it.

Please Log in to join the conversation.

More
1 month 2 weeks ago #7099 by Dirk
You probably changed the main table of your database without setting the menu parameters.

I guess you have somewhere a filter or ordering directive to a field called TITLE

Please Log in to join the conversation.

  • martijn
  • Offline
  • specialised in front end
More
1 month 2 weeks ago #7102 by martijn
Of this main database on Joomla 4 I have not made changes to the database after it linking via the extension.
Where is that supossed "title" collum you are talking about? all my collum names of the imported database do not have such a collumn name.

Please Log in to join the conversation.

More
1 month 2 weeks ago #7104 by Dirk
It`s a problem with joomla >4.1.
They are changing so much right now ... it sucks!

Please update to 4.2.2 and it should work.

Please Log in to join the conversation.

  • martijn
  • Offline
  • specialised in front end
More
1 month 2 weeks ago #7105 by martijn
I was already working with Joomla 4.2.3 as a base when the error ocurred, so Using the newest version could be the cause of the problem.
Is there any other way I could resolve this problem?

Please Log in to join the conversation.

More
1 month 2 weeks ago #7106 by Dirk
Please update to 4.2.2 and it should work.

Please Log in to join the conversation.

Moderators: Dirkjoest