Welcome, Guest
Username: Password: Remember me
If you expect answers you should describe your problem and give as much information's as possible. (SQL-Structure, Template Code, Joomla Version ...) Please read this before posting: joodb.feenders.de/support.html

TOPIC: iframe is unwanted filtered

iframe is unwanted filtered 1 year 5 months ago #4710

  • tlkl
  • tlkl's Avatar Topic Author
  • Offline
  • Posts: 13
  • Thank you received: 0
dirk wrote: If you want to be able to save empty fields you should set these fields
to NULL = Yes and disable default value!

This solved the second problem. A few weeks ago this wasn't a problem and the table was proper configures. Somehow, sometime apparently NULL changed to No. Thank you for pointing this out.

As for the stripped iframes. In global configuration selecting texteditor "None" did not work. The iframes are still stripped.

Please Log in or Create an account to join the conversation.

iframe is unwanted filtered 1 year 3 months ago #4723

  • tlkl
  • tlkl's Avatar Topic Author
  • Offline
  • Posts: 13
  • Thank you received: 0
I've also tried to put the iframe in a varchar field. I've used the next code:
<div style="padding:70.45% 0 0 0;position:relative;"><iframe src="https://player.vimeo.com/video/257118622" style="position:absolute;top:0;left:0;width:100%;height:100%;" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe></div><script src="https://player.vimeo.com/api/player.js"></script>
<p><a href="https://vimeo.com/257118622">movie-2018-01-31_14-36-30</a> from <a href="https://vimeo.com/user81703761">SmartPTLab</a> on <a href="https://vimeo.com">Vimeo</a>.</p>

After saving this was left in the varchar box:
movie-2018-01-31_14-36-30 from SmartPTLab on Vimeo.

In the textbox this was left:
<div style="padding: 70.45% 0 0 0; position: relative;"> </div>
<p> </p>
<p><a href="https://vimeo.com/257118622">movie-2018-01-31_14-36-30</a> from <a href="https://vimeo.com/user81703761">SmartPTLab</a> on <a href="https://vimeo.com">Vimeo</a>.</p>

Please Log in or Create an account to join the conversation.

iframe is unwanted filtered 1 year 3 months ago #4724

  • Dirk
  • Dirk's Avatar
  • Offline
  • Posts: 1044
  • Karma: 21
  • Thank you received: 187
Are you using JCE?
It's a jce issue

See here
/iframe-removed-on-saving

Please Log in or Create an account to join the conversation.

iframe is unwanted filtered 1 year 3 months ago #4725

  • tlkl
  • tlkl's Avatar Topic Author
  • Offline
  • Posts: 13
  • Thank you received: 0
I've changed it to using TinyMCE. I've also followed that guide when I used JCE.

Please Log in or Create an account to join the conversation.

iframe is unwanted filtered 1 year 3 months ago #4726

  • Dirk
  • Dirk's Avatar
  • Offline
  • Posts: 1044
  • Karma: 21
  • Thank you received: 187
It's not JooDB.
Maybe because you are not Super User? The the Joomla filter removes iframes.

Maybe the iframe code is not correct!
webkitallowfullscreen mozallowfullscreen allowfullscreen is wrong!

Ever tried to disable editor completely?
<iframe src="https://player.vimeo.com/video/257118622" style="position:absolute;top:0;left:0;width:100%;height:100%;" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>

Please Log in or Create an account to join the conversation.

iframe is unwanted filtered 1 year 3 months ago #4728

  • tlkl
  • tlkl's Avatar Topic Author
  • Offline
  • Posts: 13
  • Thank you received: 0
The account I'm using is a Super User. The editor settings are set to 'Editor - None'. The iframe code I've tried now is: <iframe src=" www.w3schools.com "></iframe>. Filter type for Super Users is set to 'No Filtering'.
However, the iframe is still removed during saving.

Please Log in or Create an account to join the conversation.

Last Edit: by tlkl.
Moderators: Dirkjoest