Bug with use database external in Joomla 4

More
3 weeks 4 days ago #7058 by jdelvalle
I have migrated form Joomla 3.10.11 to 4.2.2 and now the external databases do not working.

I receive the error 1146 with the message

"Table '' doesn't exist",

where "qxxx670" is the database the local site not the database remote that corresponding.

I think is a bug of Joomla 4 version.

Thanks in advance.

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #7059 by Dirk
It is caused by Joomla 4.2.2
Please wait for the next version or add a line after line 89 into /components/com_joodb/models/catalog.php
$this->setDatabase($this->_db);

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #7060 by jdelvalle
Replied by jdelvalle on topic Bug with use database external in Joomla 4
It is working now.

Thanks.

Please Log in or Create an account to join the conversation.

More
3 weeks 2 days ago - 3 weeks 2 days ago #7072 by lizwillner
Replied by lizwillner on topic Bug with use database external in Joomla 4
dirk, my app wont connect to the external database either. its also looking for the main table. additionally when i go into the , there is NO line 89 or that line anywhere in the file. i am also using the same updated setup of 4.2.2 and i have the most recent copy of joodb.

sorry i misread your instructions. it seems to be working now. sorry about that.
Last edit: 3 weeks 2 days ago by lizwillner.

Please Log in or Create an account to join the conversation.

Moderators: Dirkjoest
Powered by Kunena Forum