Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: problem with instalation on Joomla 4.0 Beta 2

problem with instalation on Jooml0 4.0 Beta 2 1 week 5 days ago #5607

  • lew229
  • lew229's Avatar Topic Author
  • Offline
  • Posts: 4
  • Thank you received: 0
I get an error in the install phase. file added

when started error message is JSubmenuHelper not found.

this has been changed in JHtmlSidebar in joomla 4 Beta 2

regards Just Lewis

Please Log in or Create an account to join the conversation.

problem with instalation on Joomla 4.0 Beta 2 3 days 18 hours ago #5614

  • lew229
  • lew229's Avatar Topic Author
  • Offline
  • Posts: 4
  • Thank you received: 0
The new error after insstall is:


Er heeft zich een fout voorgedaan.

0 Class 'JRequest' not found

Call stack
# Function Location
1 () JROOT\administrator\components\com_joodb\joodb.php:47
2 require_once() JROOT\libraries\src\Dispatcher\LegacyComponentDispatcher.php:69
3 Joomla\CMS\Dispatcher\LegacyComponentDispatcher::Joomla\CMS\Dispatcher\{closure}() JROOT\libraries\src\Dispatcher\LegacyComponentDispatcher.php:71
4 Joomla\CMS\Dispatcher\LegacyComponentDispatcher->dispatch() JROOT\libraries\src\Component\ComponentHelper.php:389
5 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT\libraries\src\Application\AdministratorApplication.php:136
6 Joomla\CMS\Application\AdministratorApplication->dispatch() JROOT\libraries\src\Application\AdministratorApplication.php:179
7 Joomla\CMS\Application\AdministratorApplication->doExecute() JROOT\libraries\src\Application\CMSApplication.php:231
8 Joomla\CMS\Application\CMSApplication->execute() JROOT\administrator\includes\app.php:63
9 require_once() JROOT\administrator\index.php:36

Please Log in or Create an account to join the conversation.

problem with instalation on Joomla 4.0 Beta 2 3 days 18 hours ago #5615

  • Dirk
  • Dirk's Avatar
  • Offline
  • Posts: 1112
  • Karma: 21
  • Thank you received: 202
Yes .... we know and we are working on this. But the missing Class is not the only problem.

Instead of JRequest you should use JFactory::getApplication()->input();

$app = JFactory::getApplication();
$app->input->get('blbla');

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: Dirkjoest